PDA

View Full Version : No Heat in Oven



GTrue
04-27-2012, 09:15 AM
Model Number: gmc305prs01
Brand: Whirlpool
Age: 1-5 years

Oven does not heat up when turned on. Broil does not work either. Do not believe it is the elements since both quick working at the same time. Tried to replace the Range Control board - 8301848 but still not heat.

WOndering what other parts would control how the oven heats. Would a fuse or the Thermastat overload safety prevent the oven from heating up?

Thanks for any input you can provide.

G

Doc Ryan
04-27-2012, 11:50 AM
Yes, the safety thermostat (thermal fuse 9759243 (http://www.partsdr.com/Parts/9759243-safety-thermal-fuse-1303.cfm)) stops the oven from heating if the oven has gotten too hot. This is common to happen if the oven has been through a self clean cycle. It can also be caused by a bad temperature senor or a bad control board, which causes the oven to get hotter than normal. You can test this part by removing it from the oven and doing a continuity test on the part. If it has continuity, then the part is good. If it doesn't have continuity, then the part is bad.

I believe part number 8301848 (http://www.partsdr.com/Parts/8301848-control-board-1789.cfm) controls the door lock latch on the oven. I don't think it relates to the heating of the oven.

If the oven has proper voltage coming into the oven (between 220-240v), and the thermal fuse is good, then the main control board W10340943 (http://www.partsdr.com/Parts/W10340943-Control-Board-2143.cfm) may not be sending power to the heating elements.