Results 1 to 12 of 12

Thread: [FIXED] Fridgidaire FGHD2433KB1 pump running all the time

  1. #1

    [FIXED] Fridgidaire FGHD2433KB1 pump running all the time

    Model Number: FGHD2433KB1
    Brand: Frigidaire
    Age: 1-5 years

    We have multiple issues here.

    It started when we noticed the rinse pump running after we returned home after several hours of being away. when we open the door, the pump stops. Float switch is good. The drain pump and the rinse pump turn freely, pump water and make no unusual noises. I cleaned the filter assembly and cleaned under the screen. I filled the sump with water and the drain pump pumped it with no issues. I started the machine and the water valve filled the machine with water, started the rinse cycle and seemed to be spraying water just fine. I drained the water and laid the machine on its side. I removed the rinse pump and the ball check is free and intact. The flapper on the outlet of the drain pump is good. All hoses are free of debris and kinks. Everything was put back together and the pump continues to run continuously. The display has always displayed the minutes remaining in the current cycle. It no longer does this. The minutes will be displayed for a minute or so then the display goes blank. If you hit the Start/cancel button it shows 17 minutes. 17 minutes happens to be the cycle time for the rinse cycle. no matter the cycle that you start the dishwasher on, when the display goes blank and you press the start/cancel button it always shows 17 minutes and the rinse cycle light illuminates. I cannot enter the diagnostic test because the pump is running. I am thinking it may be the control board (Part No. AP4567882). Any thoughts?

  2. #2
    Admin/Technician Doc Ryan's Avatar
    Join Date
    Mar 2011
    Location
    South Dakota
    Posts
    3,540
    The way your dishwasher is acting definitely does not sound normal. One thing I would try is to unplug the dishwasher and remove the ribbon cable that goes to the touchpad from the control board and power the dishwasher back up. See if the circulation pump continues to run even with the touchpad disconnected. Sometimes the touchpad can short out and cause the control board to act funny. If the dishwasher still is acting the same way then I would start by replacing the control board. Let us know what you find.

    This is the control board for your model dishwasher:

    Control Board - Part # PD00000779 (mfg # 154815601)
    Ryan
    www.PartsDr.com - Discount Appliance Parts & Accessories

    Please help keep our repair forum FREE by purchasing your replacement parts from our online store. Thank you for your support.

    Circle Parts Dr On Google+

    "Like" Parts Dr on Facebook


    Follow Parts Dr on Twitter

  3. #3
    Ryan thank you for a quick response.

    I did what you suggested and had no luck. Everything remains the same as far as pump running continuously. It ran with the keypad ribbon cable disconnected. When I removed the door cover I found instructions for the diagnostic test and was able to run it. At the end of the test it read, "CLEAN S". Looking at other posts, I am to understand this is a bad keypad? A keypad is around 135.00 and a control panel 114.00. I would like to avoid swapping parts until something works. Can you tell me what you think it might be with any certainty?

    Thanks again for the help.

  4. #4
    Ryan,

    I thought about it a little and decided if the keypad is unplugged and the pump is still on it would most likely be the control board so I ordered one thru your site. Time is an issue for me as I need to get this fixed sooner rather than later. If the keypad is the issue or another issue, I will deal with that later. Thanks for the help.

    I will update this thread after the installation of the control board.


    Greg

  5. #5
    Admin/Technician Doc Ryan's Avatar
    Join Date
    Mar 2011
    Location
    South Dakota
    Posts
    3,540
    Quote Originally Posted by gregkarih View Post
    Ryan,

    I thought about it a little and decided if the keypad is unplugged and the pump is still on it would most likely be the control board so I ordered one thru your site. Time is an issue for me as I need to get this fixed sooner rather than later. If the keypad is the issue or another issue, I will deal with that later. Thanks for the help.
    That was my thinking too. Let me know if the control board takes care of the problem once you get it installed.
    Ryan
    www.PartsDr.com - Discount Appliance Parts & Accessories

    Please help keep our repair forum FREE by purchasing your replacement parts from our online store. Thank you for your support.

    Circle Parts Dr On Google+

    "Like" Parts Dr on Facebook


    Follow Parts Dr on Twitter

  6. #6
    Well the part came in one day. Crazy quick when you pay the extra for one day air. It was the correct part and went in without issues. The motor wasn't running when I turned the machine on but ...

    Now I am getting an "ER UO" error code. I pulled the vent apart and it seems simple enough. Two wires going into a solenoid to open a vent via a plastic linkage. The coil has continuity so It would mean no power to the coil but I have power going to it... Now I need to buy a Fan/Vent assembly for 88.26 + 6.99? Frustrating to say the least.

  7. #7
    Admin/Technician Doc Ryan's Avatar
    Join Date
    Mar 2011
    Location
    South Dakota
    Posts
    3,540
    Well, that is good news that the control board has fixed the problem of the pump motor constantly running. We have a pretty large thread here that you can view about the ER UO error code. In almost every case, you have to replace the vent & fan assembly to take care of the problem.

    This is the vent & fan assembly for your model dishwasher:

    Vent & Fan Assembly - PD00000511 (mfg# 154861101)
    Ryan
    www.PartsDr.com - Discount Appliance Parts & Accessories

    Please help keep our repair forum FREE by purchasing your replacement parts from our online store. Thank you for your support.

    Circle Parts Dr On Google+

    "Like" Parts Dr on Facebook


    Follow Parts Dr on Twitter

  8. #8
    I just ordered the Vent Fan Assy. Hopefully this is the fix. Thanks again Ryan

  9. #9
    Admin/Technician Doc Ryan's Avatar
    Join Date
    Mar 2011
    Location
    South Dakota
    Posts
    3,540
    Let us know if this takes care of this issues your are having.
    Ryan
    www.PartsDr.com - Discount Appliance Parts & Accessories

    Please help keep our repair forum FREE by purchasing your replacement parts from our online store. Thank you for your support.

    Circle Parts Dr On Google+

    "Like" Parts Dr on Facebook


    Follow Parts Dr on Twitter

  10. #10
    Ryan,

    So we got the Vent/Fan assembly, installed it and we are still seeing the "ER UO" error. Any thoughts?

  11. #11
    Admin/Technician Doc Ryan's Avatar
    Join Date
    Mar 2011
    Location
    South Dakota
    Posts
    3,540
    It is possible that the new control board could be defective. I think we should warranty the control board and send you a replacement. Please click the link below to fill out the defective part form on our website. Make sure to include the dishwashers model and serial number when you fill out the form.

    http://partsdr.com/defective-part/
    Ryan
    www.PartsDr.com - Discount Appliance Parts & Accessories

    Please help keep our repair forum FREE by purchasing your replacement parts from our online store. Thank you for your support.

    Circle Parts Dr On Google+

    "Like" Parts Dr on Facebook


    Follow Parts Dr on Twitter

  12. #12
    Sorry so late on the update. Things get crazy from time to time and the update got pushed to the side.

    Long story short... the dishwasher is working.

    The new control board came while I was at work. My wife followed my instructions and swapped out the control board. She is happy. I am happy. The dishwasher appears to be just fine.

    I was not aware this type of forum existed. When I found it, I thought what have we got to lose. The prices were comparable to other sites and the advice seemed sound. If you follow the thread... I identified the problem, ordered one part, got a different fault code, ordered another part, the first part was defective and they replaced it without my asking them to. When I asked that they allow a return on the (2nd) part ordered that was not needed had the first part been defective, they allowed me to return this also. I believe that some businesses are definitely serviced based. This one is serviced based because the advice they offer but, they are here to sell parts not give advice. They choose to do this because it works for them. The customer service is top notch. There are not many like this. Progressive insurance and JPCycles are all that come to mind. If you need parts for an appliance. Buy them here and rest easy knowing they will do what they can to get you fixed up.

Similar Threads

  1. Fridgidaire ES100 Electric Range will Broil wont Bake
    By magoo12 in forum Range, Oven, & Cooktop Repairs
    Replies: 1
    Last Post: 01-16-2015, 11:18 AM
  2. Replies: 1
    Last Post: 10-17-2014, 01:11 PM
  3. GE Profile GSS22SGMBBS water inlet valve solenoid getting power all the time
    By wireready in forum Refrigerator or Freezer Repair
    Replies: 1
    Last Post: 02-09-2014, 12:13 PM
  4. Washer won't spin all the time
    By Panda1pie in forum Washer Repair
    Replies: 3
    Last Post: 10-04-2012, 09:10 AM
  5. Replies: 5
    Last Post: 11-02-2011, 09:00 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •