Results 1 to 7 of 7

Thread: Replaced GE wall oven and now No Lights No Clock No Power

  1. #1

    Replaced GE wall oven and now No Lights No Clock No Power

    Model Number: JTP20BF
    Brand: Brand
    Age: Less than 1 year

    GE Profile wall oven Model JPT20BF

    Hope this isn't too wordy. New at the forum thing...

    Scenario: Someone gave me a nice working GE Profile wall oven model JTP20

    Existing Magic Chef (worked just fine) oven is hardwired along with the electric range top to (two) hots (10ga I believe) and one 10ga stranded aluminum as ground in a 100amp SUB Panel. The 400amp main panel is on the other side of the house. The sub panel is in the garage.

    Problem:
    1. I removed the magic chef oven to replace it with the GE Profile. I wired the ground to the ground from the feed and ignored the white neutral.

    2. Before pushing it into the cabinet space I tested everything and it all worked fine. I shut off the breaker, pushed it into the wall, turned on the breaker and nothing. No lights, no clock. the range top works but absolutely no lights on the oven. No way to reset the oven (according to manual) because there are no lights.

    3. Shut off the breaker for 10 minutes and tried again. Nothing. range works fine (both wired together in gang box).

    4. I pulled the oven figuring I had a loose connection. All good. tested both leads are hot.

    5. Tested power from the romex at the junction box and going into the oven's interior connection. There's 240 power all the way through. 120 on each leg to ground.

    6. Gave up and re-installed the old magic chef oven. Turned on the breaker and now THAT oven doesn't work either!!! No lights! Nothing. The range top still works fine.

    7. I find it hard to believe I burnt both controller boards but I've done worse in my life.

    Last effort: I have a 240 outlet in the garage on a separate circuit. I bought a 50A plug to match, attached it to the GE profile and plugged it in. Nothing. Haven't tried the magic chef yet. Should I try connecting the white neutral to the feed ground instead of the ground?

    Humbled and hoping someone can help.

  2. #2
    I am not sure if I understand the following:
    I wired the ground to the ground from the feed and ignored the white neutral
    If you mean that the Neutral on the oven now has nothing connected then you wired it wrong.

    On a 3 wire hook up L1 and L2 are conncted to the hots in the stove and it sounds like you did this correctly.
    The third wire which you say is ground has to he connected to Neutral in the stove.
    It should actually be wired to a Neutral in the box.
    Then a jumper wire/ground strap goes from Neutral in the stove to the oven's frame (unit ground)

    It could be that this is your only problem since the oven light is probably controled just through the door switch not the control board.
    Unless of coarse the bulb is burned out.

    I cannot even guess why it worked OK when you tested it.
    Last edited by denman; 09-21-2018 at 09:00 AM.

  3. #3
    Thank you, Denman. I don't recall white neutral from the stove being attached to anything but I'm sure as you say, it was.

    If I'm understanding you correctly then the white from the stove attaches to the bare wire (ground) in the junction box. What do I do with the ground wire from the stove?

    I much appreciate all your responses. My wife is afraid I'm going to burn the house down. I'm starting to believe her.

  4. #4
    The oven light, control board and fan usually get power from L1 to Neutral, so Neutral must be connected.
    Neutral and ground are not connected in the unit.
    This is so that it can be used with 4 wire hookups where Neutral and ground are separate.

    A ground strap is normally used to connect Neutral and the oven's frame for 3 wire hookups but in your case it sounds like you have a Neutral and a ground wire in the units conduit so they have to be connected together at the Neutral in the junction box.

    It is very important to connect them together.
    If you do not and either of the hots shorts to the unit's frame the frame becomes live.
    Touch it and anything grounded and you will get a nasty shock.

  5. #5
    Thanks for all your help, Denman! I am going to do that and report back.

  6. #6
    It's All good!!! Thank you, thank you, thank you!

  7. #7
    You are welcome.
    Glad to hear that you are up and running.

Similar Threads

  1. Whirlpool RBS245PRS04 panel lights out, no power
    By maky in forum Range, Oven, & Cooktop Repairs
    Replies: 2
    Last Post: 10-02-2016, 06:53 PM
  2. Frigidaire Double Wall Oven won't heat
    By Miss W in forum Range, Oven, & Cooktop Repairs
    Replies: 3
    Last Post: 05-14-2016, 10:07 PM
  3. broiler and oven won't heat up but the stove top and clock work fine
    By spiffy in forum Range, Oven, & Cooktop Repairs
    Replies: 1
    Last Post: 02-16-2015, 05:07 PM
  4. Replaced the clock /control module today but the oven still will not heat
    By Bro_Ed in forum Range, Oven, & Cooktop Repairs
    Replies: 3
    Last Post: 10-11-2013, 01:48 PM
  5. wall oven touch pad
    By dj4 in forum Range, Oven, & Cooktop Repairs
    Replies: 1
    Last Post: 02-24-2012, 11:25 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •