Results 1 to 2 of 2

Thread: GE Dishwasher heating problem

  1. #1

    GE Dishwasher heating problem

    Model Number:
    Brand: Brand
    Age: Less than 1 year

    Model Number: GDF540HMF6ES
    Brand: GE
    Age: 1-5 years

    For some reason the heating element on our dishwasher is not coming on during the wash cycle. I used the diagnostics to confirm that the element works, but the unit will run through a cycle and not heat up no matter what settings we use. We normally use the heavy wash function with steam, sanitize and heat dry so the element should definitely be coming on. I replaced the wash pump kit a few months ago and used all the new wiring harnesses. It worked normally for a few months until last week. At first I thought maybe the element had just burned out because it had been run a few times before we realized that the wash pump was dead and I thought maybe it overheated. As far as I can tell this unit doesn't have a replaceable thermostat or thermistor anywhere. I'm thinking it must be the control board, but if the element will come on during the diagnostics, whatever on the control board turns the element on is obviously still working. I've seen some comments online that the turbidity sensor or float sensor can affect the heating, but, at least from what I can tell, those appear to be OK and most claims of those being the culprit seem to be overturned by a technician online.

    Before I drop $175 on a new control board I'd like to exhaust any other possible options. Still cheaper than a new dishwasher, but still

  2. #2
    I realize I'm adding to my own thread with no replies however after reading some of the other similar issues I think I might be narrowing this down. First the reason I could not find a thermostat anywhere is it is apparently part of the wiring harness for that wash pump that I replaced a few months ago. Bad news is I might have a bad harness, good news, should still be under warranty. I'm going to check with a multi-meter tonight. I've also found a few people mention that after cleaning their float sensors out the heating element started to work again - due to gunk that didn't dilute properly because of low water temp. So I think I'll clean that out with some hot water and compressed air tonight. Maybe it's just stuck.

Similar Threads

  1. Kenmore Dishwasher Heating Issue
    By EricNYS in forum Dishwasher Repair
    Replies: 0
    Last Post: 11-21-2018, 01:22 PM
  2. Frigidaire dishwasher problem
    By amv429 in forum Dishwasher Repair
    Replies: 0
    Last Post: 03-27-2017, 11:52 AM
  3. Replies: 1
    Last Post: 03-13-2017, 01:29 PM
  4. Portable Dishwasher Problem
    By eghirarduzzi in forum Dishwasher Repair
    Replies: 1
    Last Post: 04-04-2016, 06:29 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •