Results 1 to 9 of 9

Thread: Samsung Range Convection Element won't heat

  1. #1

    Samsung Range Convection Element won't heat

    Model Number:
    Brand: Brand
    Age: Less than 1 year

    Model Number: NE595R0ABSR/AA-0000
    Brand: Samsung
    Age: 1-5 years

    The convection heat element (Part # DG47-00017A) does not heat. I replaced it with a new part and it still does not heat. I used a multimeter on both the old part and the new part. Neither one shows continuity on the meter. The element in the top of the oven is working fine and the multimeter shows that it has continuity. Do you have any idea what the problem is?

  2. #2
    Make sure you are on the correct resistance scale.
    The element should be about 72 ohms.

    If not you may have a bad replacement element.

  3. #3
    Quote Originally Posted by denman View Post
    Make sure you are on the correct resistance scale.
    The element should be about 72 ohms.

    If not you may have a bad replacement element.
    It reads nothing either with the continuity setting or the ohms setting.

  4. #4
    Then I would say that the replacement element is also bad.

  5. #5

    Smile

    Quote Originally Posted by denman View Post
    Then I would say that the replacement element is also bad.
    Thank you. I have requested another replacement part.

  6. #6
    Quote Originally Posted by PBurroughs View Post
    Thank you. I have requested another replacement part.
    The convection bake element reads 71 on the multimeter but it still does not heat. Any ideas

  7. #7
    Do you have the wiring diagram.
    I cannot find one for this specific unit but have found info on a NE597 but am not sure how close a match it is.

    If the unit has the element control relays on the control board then it is probably a bad control board.
    Also may be a bad connection between the control board and the element.
    I am assuming that the bake and broil elements work OK.

    Note: Some units have a relay board so check that the convection element control wire goes directly to the control board/clock.

  8. #8

    Samsung Range Convection Element won't heat

    Quote Originally Posted by denman View Post
    Do you have the wiring diagram.
    I cannot find one for this specific unit but have found info on a NE597 but am not sure how close a match it is.

    If the unit has the element control relays on the control board then it is probably a bad control board.
    Also may be a bad connection between the control board and the element.
    I am assuming that the bake and broil elements work OK.

    Note: Some units have a relay board so check that the convection element control wire goes directly to the control board/clock.
    I replaced the control board and it still does not heat. There are a hundred wires in the back of the range but none of them appear to be bad. I have no idea where to go from here. I do have the wiring diagram but as I am not an appliance repair technician it doesn't make much sense to me.

  9. #9
    Then it may be best to get a tech in.

Similar Threads

  1. Replies: 1
    Last Post: 05-06-2014, 01:56 PM
  2. Samsung Dryer Won't Heat - Checked Heating Element and Thermostat
    By ashleynjefferson in forum Dryer Repair
    Replies: 1
    Last Post: 01-30-2014, 01:05 PM
  3. Replies: 5
    Last Post: 11-11-2013, 03:09 PM
  4. Replies: 6
    Last Post: 09-05-2013, 12:22 PM
  5. Amana Electric Range replaced bake element won't heat
    By Wyler in forum Range, Oven, & Cooktop Repairs
    Replies: 1
    Last Post: 11-06-2011, 08:51 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •