Results 1 to 2 of 2

Thread: Kenmore kicking off after preheat

  1. #1

    Kenmore kicking off after preheat

    Model Number:
    Brand: Sears Kenmore
    Age: 6-10 years

    I have a new oven in storage but have been using an LP Kenmore in our basement. It started kicking off during baking so I replaced the igniter. It worked perfect for a couple of times and then started having issues again. I then replaced the temperature sensor to see if that was the issue. Now the oven will preheat just fine but shuts off after the preheat beep.

  2. #2
    Model number 790.72903013

    Wasn't able to get to it earlier.

    Quote Originally Posted by Lunamoon42 View Post
    Model Number:
    Brand: Sears Kenmore
    Age: 6-10 years

    I have a new oven in storage but have been using an LP Kenmore in our basement. It started kicking off during baking so I replaced the igniter. It worked perfect for a couple of times and then started having issues again. I then replaced the temperature sensor to see if that was the issue. Now the oven will preheat just fine but shuts off after the preheat beep.

Similar Threads

  1. Frigidaire Evaporator Fan Not Kicking On
    By nrsheare in forum Refrigerator or Freezer Repair
    Replies: 0
    Last Post: 07-12-2018, 06:30 PM
  2. Kenmore oven does not switch from preheat to normal oven setting
    By Gopher72 in forum Range, Oven, & Cooktop Repairs
    Replies: 0
    Last Post: 11-21-2016, 04:19 PM
  3. Both Elements for preheat?
    By luckytx2001 in forum Range, Oven, & Cooktop Repairs
    Replies: 3
    Last Post: 01-12-2013, 06:49 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •