Page 3 of 3 FirstFirst 123
Results 41 to 45 of 45

Thread: [FIXED] Samsung dryer runs, no lint clogs, good airflow, but no heat at all

  1. #41

    We are having the same problem too. The dryer isn't heating, there is no air flow problem, the incoming electricity is at the correct voltage, and there are no Error codes. We have replaced the whole heating element assembly complete with the thermostat, cut off fuses, and the thermoster. We noticed that once that it was started and said the time was 40 min, and got something to drink and came back after 2 min and the time said 20 min. Could this be the control board? I thought it was a timer problem, but I can't find that in the parts diagram. Considering buying a dryer, but not a Samsung as it seems that they are built to only last 4 years. This is our first time trying to fix a dryer, so any help would be appreciated. Perhaps I should be asking what a good dryer brand is too! hahaha.

    Model number is DV42H5000EW/A3 (i don't know the next 4 numbers as its not in the door)
    Electric not gas model.
    Last edited by cheryl; 02-04-2018 at 12:25 PM. Reason: wanted to be more exact

  2. #42
    Quote Originally Posted by jeffsears View Post
    Overheated or bad motor (possible thermal overload) could be the reason.
    For those of you that are at sits end because you have checked airflow, all parts of the heating system (element, fuse, thermistor, etc.) And checked the voltage plus the main control board, but still cant find the problem, I may have the answer for you. The centrifugal switch may have gone bad on your motor. Bad news is, that you cant buy this little switch by itself, you have to buy the whole motor, even though your motor is still good. :-( Basically, this switch is used to tell the brain that the drum is turning and it can now heat. If the contact doesnt work, or isn't strong enough because a little nubby fell out of it, then your dryer wont heat. This is to prevent the heater from just staying in the on position and starting a fire. On a positive note, your house didn't burn down, but you will have to buy the entire motor and take your dryer apart. I dont think you can replace a motor from the vent slot in the back.

  3. #43
    We recently have had the same issues. Our dryer will start and run, but will not heat. We just replaced the heating element and the thermostat and we are still not getting any heat. After replacing we noticed on the control panel the ‘cooling’ was on. Any help is appreciated!

  4. #44
    Join Date
    Mar 2016
    What is your model number?

    Have you tried different cycle types re: auto, timed dry and different heat settings etc.?

    Is it possible that you are in an auto mode and when you replaced the heater you forgot to reconnect the moisture sensor bars?

  5. #45
    I also have the problem with my relay not reading 120 when running. What part do I order to replace

Similar Threads

  1. lint seal missing.....passing lots of lint
    By midlife fixer in forum Dryer Repair
    Replies: 1
    Last Post: 02-14-2013, 04:51 PM
  2. [FIXED] Whirlpool Dryer lint fire thermistor blew
    By Treespalette in forum Dryer Repair
    Replies: 7
    Last Post: 02-04-2013, 09:08 PM
  3. Maytag Dryer starts heats and runs, then shuts off
    By Jeff Gray in forum Dryer Repair
    Replies: 1
    Last Post: 12-16-2011, 05:59 PM
  4. Samsung Electric Dryer won't heat
    By Xion2 in forum Dryer Repair
    Replies: 3
    Last Post: 10-09-2011, 10:05 PM
  5. Amana dryer runs but no heat???
    By Fit44 in forum Dryer Repair
    Replies: 4
    Last Post: 05-21-2011, 02:21 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts