Results 1 to 11 of 11

Thread: Replaced the thermostat kit worked for 4 loads and then won't heat

  1. #1

    Replaced the thermostat kit worked for 4 loads and then won't heat

    Model Number: Gew9250pw0
    Brand: Whirlpool
    Age: 6-10 years

    I replaced the thermostat kit this weekend, cleaned out all the lint in the machine, in exhaust and everywhere I checked the element for continuity and is good, also does not continuity to ground, what else would make the hi temp thermostat blow again the kit number that I replaced was 279973 thanks in advance

  2. #2
    Join Date
    Mar 2016
    Although you did not say I am assuming that the thermal cut-off blew.
    It is a back up for the high limit which has contacts that do not last very long.

    See the attachment for the tech sheet.

    Check the thermistor resistance.

    If the themistor is good then odds are that the control board is toast.
    Either the contacts in the heater relay are welded together or the electronics that control the relau are holding the contacts closed all the time.

  3. #3
    The thermostat doesn't have continuity again, ( the one on the heat element tube but furthest away from the heat element contacts) this was the same one that went bad last time

  4. #4
    Join Date
    Mar 2016
    That looks like it is the thermal cutoff (thermal fuse).
    The other one is the hi-limit thermostat.

    The way it works is that if for some reason the heater gets too hot the high limit thermostat opens killing power to the element.
    It is a safety device so should not open unless there is a problem.
    When the heater cools down some the hi-limit resets itself and the unit again heats.

    The problem is that the hi limit's contacts are not that robust so after a while they fail often welding themselves together.
    Now here is where the thermal cutoff come in as it is like a thermal fuse so it blows and does not reset.

    Thay is why they are sold as a set manufacturers assume that there must be a problem with the high limit for the cutoff to blow.

  5. #5
    Ok I checked the thermistor and at 78 degrees it had 9.6 ohms resistance, but when I was checking it I found wires melted together that go to it, I don't know if that was my problem, when I was pulling the wires apart the red wire pulled the insulation back and exposed the wire, is it ok to put heat shrink on the wire and separate them or what should I do with that, I don't know if the wire actually touched each other or just the insulation melted together, after repairing the wires should I put a new thermal fuse in it and just try the dryer or should I check something else??

  6. #6
    Join Date
    Mar 2016
    Looks like the thermistor is bad.

    Or is it 9.6Kohms (9600 ohms) and not 9.6 ohms.

    Once the thermsitor is OK then replace the hi-limit and cutoff again but test the dryer at a lower heat setting to be sure it is regulating the heat.

  7. #7
    Sorry it is 9.6 k ohms

  8. #8
    That means it's ok correct??? If that's correct should I just fix the wires and try it or do you think it's going to be the control board

  9. #9
    Admin/Technician Doc Ryan's Avatar
    Join Date
    Mar 2011
    South Dakota
    Try running the dryer on the air dry (no heat) cycle to see if it still produces heat. If it does then the heating element might be shorted, or the main control board is bad.
    - Discount Appliance Parts & Accessories

    Please help keep our repair forum FREE by purchasing your replacement parts from our online store. Thank you for your support.

    Check out our Repair Videos on Youtube

    "Like" Parts Dr on Facebook

    Follow Parts Dr on Twitter

  10. #10
    Well I put the new parts in and fixed the wires up and checked it on air dry and it is NOT producing heat on air dry, is there anything else I should check or should I just use it and see what happens?

  11. #11
    Join Date
    Mar 2016
    Try lower heeat settings to see if it now controls the heat output.

Similar Threads

  1. Replies: 1
    Last Post: 10-02-2014, 05:49 PM
  2. Samsung Dryer Won't Heat - Checked Heating Element and Thermostat
    By ashleynjefferson in forum Dryer Repair
    Replies: 1
    Last Post: 01-30-2014, 01:05 PM
  3. Replies: 5
    Last Post: 11-11-2013, 03:09 PM
  4. Replies: 6
    Last Post: 08-15-2013, 03:12 PM
  5. [FIXED] Whirlpool not dryer (2-3 loads to dry)
    By JusFlako in forum Dryer Repair
    Replies: 10
    Last Post: 11-27-2012, 11:14 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts